Ruby Debug IDE error : ruby-debug-ide-0.4.9/lib/ruby-debug-ide.rb:109:in `debug_load'

Posted by Paul on Stack Overflow See other posts from Stack Overflow or by Paul
Published on 2010-06-07T07:17:12Z Indexed on 2010/06/07 7:22 UTC
Read the original article Hit count: 901

Filed under:
|
|
|

I hope someone can assist me. I have RubyMine 2.0.2 installed on Windows 7 32 bit computer. Since a week ago (I presume it must have been after I have update some gems) I cant seem to debug form the IDE. I am trying to debug a rake task which I could before. Running the rake task normally works perfect, just debug doesnt. Its not just limited to the rake, I cant debug any ruby files. I've tried installing older versions of debug-ide and debug-base but to no success. I've tried it with ruby 1.8.7 and 1.8.6 on different computers but nothing. Trying to search the web gave some information, which I've tried, but also no success. Im desperate to get this working. Below are the full error and my current settings:

Error:

C:\InstantRails\ruby\bin\ruby.exe -e STDOUT.sync=true;STDERR.sync=true;load($0=ARGV.shift) C:\InstantRails\ruby\bin/rdebug-ide --port 57167 -- C:/InstantRails/rails_apps/paperserve/lib/tasks/poll_snmp.rake Fast Debugger (ruby-debug-ide 0.4.9) listens on :57167

C:/InstantRails/rails_apps/paperserve/lib/tasks/poll_snmp.rake:5

C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.9/lib/ruby-debug ide.rb:109:in `debug_load'

C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.9/lib/ruby-debug ide.rb:109:in `debug_program'

C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.9/bin/rdebug-ide:87

C:\InstantRails\ruby\bin/rdebug-ide:19:in `load'

C:\InstantRails\ruby\bin/rdebug-ide:19

-e:1:in `load'

-e:1 Uncaught exception: undefined method `namespace' for main:Object

Process finished with exit code 1

Code snippet (It fails at the start of namespace. If I remove this, it fails on the next line, etc, etc)

#This script should run every 15 minutes 
require 'snmp' 
require 'yaml'

namespace :cdeweb do

RubyGems Environment:

  • RUBYGEMS VERSION: 1.3.7 RUBY VERSION:
  • 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32] INSTALLATION
  • DIRECTORY:
  • C:/InstantRails/ruby/lib/ruby/gems/1.8
  • RUBY EXECUTABLE:
  • C:/InstantRails/ruby/bin/ruby.exe
  • EXECUTABLE DIRECTORY:
  • C:/InstantRails/ruby/bin RUBYGEMS
  • PLATFORMS:

    • ruby
    • x86-mswin32-60
  • GEM PATHS:

    • C:/InstantRails/ruby/lib/ruby/gems/1.8
    • C:/Users/Paul.LPFSYSTEMS/.gem/ruby/1.8
  • GEM CONFIGURATION:

    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
  • REMOTE SOURCES:

* LOCAL GEMS *

  • actionmailer (2.3.5, 2.0.2)
  • actionpack (2.3.5, 2.0.2)
  • activerecord (2.3.5, 2.0.2)
  • activeresource (2.3.5, 2.0.2)
  • activesupport (2.3.5, 2.0.2)
  • capistrano (2.5.18, 2.1.0)
  • cgi_multipart_eof_fix (2.5.0)
  • cmdparse (2.0.2) columnize (0.3.1)
  • fxri (0.3.7, 0.3.6) fxruby (1.6.12 mswin32)
  • gem_plugin (0.2.3)
  • highline(1.5.2, 1.4.0)
  • hpricot (0.8.2 x86-mswin32, 0.6 mswin32)
  • inaction_mailer (0.6)
  • json (1.4.2 x86-mswin32)
  • json_pure (1.4.2)
  • linecache (0.43 mswin32)
  • log4r (1.1.7, 1.0.5)
  • mongrel (1.1.5 x86-mswin32-60, 1.1.2 mswin32)
  • mysql(2.8.1 x86-mswin32, 2.7.3 mswin32)
  • needle (1.3.0)
  • net-scp (1.0.2)
  • net-sftp (2.0.4, 1.1.0)
  • net-ssh (2.0.22, 1.1.2)
  • net-ssh-gateway (1.0.1)
  • rack (1.0.1)
  • rails (2.3.5, 2.0.2)
  • rake (0.8.7, 0.8.1, 0.8.0, 0.7.3)
  • ruby-debug-base (0.10.3 mswin32)
  • ruby-debug-ide (0.4.9)
  • ruby-net-ldap (0.0.4)
  • rubygems-update (1.3.7, 1.3.6, 1.0.1)
  • snmp (1.0.2)
  • sources (0.0.1)
  • sqlite3-ruby (1.2.5 x86-mswin32, 1.2.1 mswin32)
  • win32-api (1.4.6 x86-mswin32-60, 1.0.4 mswin32)
  • win32-clipboard (0.5.2, 0.4.3)
  • win32-dir (0.3.6, 0.3.2)
  • win32-eventlog (0.5.2, 0.4.6)
  • win32-file (0.6.3, 0.5.4)
  • win32-file-stat (1.3.4, 1.2.7)
  • win32-process (0.6.2, 0.5.3)
  • win32-sapi (0.1.5, 0.1.4)
  • win32-sound (0.4.2, 0.4.1)
  • windows-api (0.4.0, 0.2.0)

© Stack Overflow or respective owner

Related posts about ruby

Related posts about rubygems