In 12.04: Failed to load session 'ubuntu' [closed]

Posted by Stéphane on Ask Ubuntu See other posts from Ask Ubuntu or by Stéphane
Published on 2012-03-19T16:39:49Z Indexed on 2012/03/19 18:14 UTC
Read the original article Hit count: 872

Filed under:
|
|

Possible Duplicate:
There's an issue with an Alpha/Beta Release of Ubuntu, what should I do?

I'm using 12.04 beta. Today I was prompted to install some updates, which I did, followed by a reboot. On reboot, X starts, but all I see is a single dialog window in the middle of the screen with the text: Failed to load session 'ubuntu' I don't even see the mouse, or the login screen, just this 1 line of text.

When I hit CTRL+ALT+F1 to run dist-upgrade from a command prompt, I get this:

The following packages have been kept back:
  libgnome-desktop-3-2

So to see why it was kept back, I tried the following:

$ sudo apt-get install libgnome-desktop-3-2
...
The following packages have unmet dependencies:
 libgnome-desktop-3-2 : Depends: gnome-desktop3-data (= 3.3.92-0ubuntu1) but 3.3.91-0ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

Anyone else seeing this, or have an idea how to fix it?


If you're going to close it as a duplicate, can you please link to the duplicate question?

© Ask Ubuntu or respective owner

Related posts about updates

Related posts about gnome3