git pull gives error: 401 Authorization Required while accessing https://git.foo.com/bar.git

Posted by spuder on Stack Overflow See other posts from Stack Overflow or by spuder
Published on 2013-05-15T18:19:36Z Indexed on 2013/06/25 16:21 UTC
Read the original article Hit count: 651

Filed under:

My macbook pro is able to clone/push/pull from the company git server. My cent 6.3 vm gets a 401 error

git clone https://git.acme.com/git/torque-setup
"error: The requested URL returned error: 401 Authorization Required while accessing https://git.acme.com/git/torque-setup/info/refs

As a work around, I've tried creating a folder, with an empty repository, then setting the remote to the company server. I get the same error when trying a git pull

The remotes are identical between the machines

MacBook Pro (working)

git --version
git version 1.7.10.2 (Apple Git-33)

git remote -v
origin  https://git.acme.com/git/torque-setup (fetch)
origin  https://git.acme.com/git/torque-setup (push)

Cent 6.3 (not working)

yum install -y git

git --version
git version 1.7.1

git remote -v
origin  https://git.acme.com/git/torque-setup (fetch)
origin  https://git.acme.com/git/torque-setup (push)


The git server only allows https. Not git or ssh connections.

Why is the macbook pro able to do a git pull, while the cent os machine can't?


Solution Update 2013-5-15

As jku mentioned, the culprit is the old version of git installed on the cent box. Unfortunately, 1.7.1 is what you get when you run yum install git

The work around is to manually install a newer version of git, or simply add the username to the repo

git clone https://[email protected]/git/torque-setup

© Stack Overflow or respective owner

Related posts about git