Migrated SCOM 2007 R2 Reporting Services but reports are gone

Posted by Gabriel Guimarães on Server Fault See other posts from Server Fault or by Gabriel Guimarães
Published on 2010-12-28T12:46:16Z Indexed on 2010/12/28 12:55 UTC
Read the original article Hit count: 345

I've migrated Reporting Services on a SCOM 2007 R2 install, and noticed that the reports have not being copied. I can create a new report, but the ones I've had because of the management packs are gone. I've tried re-applying the Management Packs however it doesn't re-deploy them and when I try to access for example:

Monitoring -> Microsoft Windows Print Server -> Microsoft Windows Server 2000 and 2003 Print Services -> State View -> select any item and click Alerts on the right menu.

I get the following error:

Date: 12/24/2010 12:40:35 PM

Application: System Center Operations Manager 2007 R2

Application Version: 6.1.7221.0

Severity: Error

Message: Cannot initialize report.

Microsoft.Reporting.WinForms.ReportServerException: The item '/Microsoft.SystemCenter.DataWarehouse.Report.Library/Microsoft.SystemCenter.DataWarehouse.Report.Alert' cannot be found. (rsItemNotFound) at Microsoft.Reporting.WinForms.ServerReport.GetExecutionInfo() at Microsoft.Reporting.WinForms.ServerReport.GetParameters() at Microsoft.EnterpriseManagement.Mom.Internal.UI.Reporting.Parameters.ReportParameterBlock.Initialize(ServerReport serverReport) at Microsoft.EnterpriseManagement.Mom.Internal.UI.Console.ReportForm.SetReportJob(Object sender, ConsoleJobEventArgs args)

The report doesn't exist on the reporting services side. how do I re-deploy this reports? Any help is appreciated. Thanks in advance.

© Server Fault or respective owner

Related posts about reporting-services

Related posts about scom-2007-r2