PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/json.so' undefined symbol: ZVAL_DELREF

Posted by crmpicco on Server Fault See other posts from Server Fault or by crmpicco
Published on 2012-04-03T16:55:59Z Indexed on 2012/04/03 17:32 UTC
Read the original article Hit count: 3093

Filed under:
|
|
|
|

I have an issue where I am unable to use JSON, which would appear to be because of the following error. There is another thread on this forum this touches on a similar issue, but it's not quite the same.

I am using CentOS 5.6 and have the following pear packages installed:

[crmpicco@eq-www-php53 ~]$ pear list
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/json.so' - /usr/lib64/php/modules/json.so: undefined symbol: ZVAL_DELREF in Unknown on line 0
Installed packages, channel pear.php.net:
=========================================
Package          Version State
Archive_Tar      1.3.7   stable
Auth_SASL        1.0.2   stable
Console_Getopt   1.3.1   stable
Image_Barcode    1.1.2   stable
Mail             1.1.14  stable
Net_SMTP         1.2.10  stable
Net_Socket       1.0.8   stable
PEAR             1.9.4   stable
Structures_Graph 1.0.4   stable
XML_RPC          1.5.4   stable
XML_Util         1.2.1   stable
json             1.2.1   stable

and have the following PHP packages installed:

[crmpicco@eq-www-php53 ~]$ yum list installed | grep php
php.x86_64                           5.3.10-1.w5                       installed
php-cli.x86_64                       5.3.10-1.w5                       installed
php-common.x86_64                    5.3.10-1.w5                       installed
php-devel.x86_64                     5.3.10-1.w5                       installed
php-gd.x86_64                        5.3.10-1.w5                       installed
php-ldap.x86_64                      5.3.10-1.w5                       installed
php-mcrypt.x86_64                    5.3.10-1.w5                       installed
php-mysql.x86_64                     5.3.10-1.w5                       installed
php-pdo.x86_64                       5.3.10-1.w5                       installed
php-pear.noarch                      1:1.9.4-1.w5                      installed
php-pear-Net-Socket.noarch           1.0.8-1.el5.centos                installed
php-soap.x86_64                      5.3.10-1.w5                       installed
php-xml.x86_64                       5.3.10-1.w5                       installed

The error:

[crmpicco@eq-www-php53 ~]$ php -v
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/json.so' - /usr/lib64/php/modules/json.so: undefined symbol: ZVAL_DELREF in Unknown on line 0
PHP 5.3.10 (cli) (built: Feb  2 2012 23:23:12)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies

My repolist reads as:

[crmpicco@eq-www-php53 ~]$ yum repolist
Loaded plugins: changelog, fastestmirror
Excluding Packages in global exclude list
Finished
repo id                                                           repo name                                                                                                status
base                                                              CentOS-5 - Base                                                                                           3,548+43
epel                                                              Extra Packages for Enterprise Linux 5 - x86_64                                                           6,815+156
extras                                                            CentOS-5 - Extras                                                                                           245+23
rpmforge                                                          Red Hat Enterprise 5 - RPMforge.net - dag                                                                11,016+67
updates                                                           CentOS-5 - Updates                                                                                             233
webtatic                                                          Webtatic Repository 5 - x86_64                                                                             211+183
repolist: 22,068

I am getting HTTP 500 errors everywhere that I use JSON so my application is non functional right now.

© Server Fault or respective owner

Related posts about php

Related posts about installation