PHP Pear Installation on CentOS

Posted by Prabhakar on Server Fault See other posts from Server Fault or by Prabhakar
Published on 2012-02-11T21:41:58Z Indexed on 2012/04/04 5:31 UTC
Read the original article Hit count: 2397

Filed under:
|
|
|
|
[[email protected] ~]# yum install php-pear*
Reducing CentOS-5 Testing to included packages only
Finished
Setting up Install Process
Package 1:php-pear-1.8.1-2.el5.centos.noarch already installed and latest versio                                                                                                                      n
Package php-pear-XML-Util is obsoleted by php-pear, trying to install 1:php-pear                                                                                                                      -1.8.1-2.el5.centos.noarch instead
Package 1:php-pear-1.8.1-2.el5.centos.noarch already installed and latest versio                                                                                                                      n
Package php-pear-DB is obsoleted by php-pear-db, trying to install php-pear-db-1                                                                                                                      .7.13-2.el5.rf.noarch instead
Resolving Dependencies
--> Running transaction check
---> Package php-pear-Auth-RADIUS.noarch 0:1.0.6-1.el5 set to be updated
--> Processing Dependency: php-pecl(radius) >= 1.2.5 for package: php-pear-Auth-                                                                                                                      RADIUS
--> Processing Dependency: php-mcrypt for package: php-pear-Auth-RADIUS
---> Package php-pear-Auth-SASL.noarch 0:1.0.4-1.el5 set to be updated
---> Package php-pear-Benchmark.noarch 0:1.2.7-1.el5 set to be updated
---> Package php-pear-CAS.noarch 0:1.1.3-1.el5 set to be updated
--> Processing Dependency: php-domxml-php4-php5 for package: php-pear-CAS
---> Package php-pear-Cache-Lite.noarch 0:1.7.5-1.el5 set to be updated
---> Package php-pear-CodeGen.noarch 0:1.0.7-3.el5 set to be updated
---> Package php-pear-CodeGen-PECL.noarch 0:1.1.3-3.el5 set to be updated
---> Package php-pear-Console-CommandLine.noarch 0:1.1.3-3.el5 set to be updated
---> Package php-pear-Console-Getargs.noarch 0:1.3.5-1.el5 set to be updated
---> Package php-pear-Console-ProgressBar.noarch 0:0.5.2-0.2.beta.el5 set to be                                                                                                                       updated
---> Package php-pear-Console-Table.noarch 0:1.1.1-1.el5 set to be updated
---> Package php-pear-Crypt-Blowfish.noarch 0:1.0.1-1.el5 set to be updated
---> Package php-pear-Crypt-CHAP.noarch 0:1.0.2-1.el5 set to be updated
---> Package php-pear-DB-DataObject.noarch 0:1.8.12-1.el5 set to be updated
---> Package php-pear-DB-DataObject-FormBuilder.noarch 0:1.0.0-1.el5 set to be u                                                                                                                      pdated
---> Package php-pear-DB-QueryTool.noarch 0:1.1.2-1.el5 set to be updated
---> Package php-pear-Date.noarch 0:1.4.7-2.el5.centos set to be updated
---> Package php-pear-Date-Holidays.noarch 0:0.21.4-1.el5 set to be updated
---> Package php-pear-Date-Holidays-USA.noarch 0:0.1.1-1.el5 set to be updated
---> Package php-pear-Event-Dispatcher.noarch 0:1.1.0-1.el5 set to be updated
---> Package php-pear-File.noarch 0:1.2.2-1.el5.centos set to be updated
---> Package php-pear-File-Find.noarch 0:1.3.0-1.el5 set to be updated
---> Package php-pear-File-Passwd.noarch 0:1.1.7-1.el5 set to be updated
---> Package php-pear-File-SMBPasswd.noarch 0:1.0.3-1.el5 set to be updated
---> Package php-pear-HTML-Common.noarch 0:1.2.5-1.el5 set to be updated
---> Package php-pear-HTML-QuickForm.noarch 0:3.2.12-1.el5 set to be updated
---> Package php-pear-HTML-QuickForm-ElementGrid.noarch 0:0.1.1-1.el5 set to be                                                                                                                       updated
---> Package php-pear-HTML-QuickForm-advmultiselect.noarch 0:1.4.1-1.el5 set to                                                                                                                       be updated
---> Package php-pear-HTML-Table.noarch 0:1.7.5-1.el5 set to be updated
---> Package php-pear-HTML-Template-IT.noarch 0:1.3.0-2.el5 set to be updated
---> Package php-pear-HTML_Template_PHPLIB.noarch 0:1.4.0-2.el5 set to be update                                                                                                                      d
---> Package php-pear-HTTP.noarch 0:1.4.0-7.el5 set to be updated
---> Package php-pear-HTTP-Client.noarch 0:1.1.1-1.el5 set to be updated
---> Package php-pear-HTTP-Request.noarch 0:1.4.4-1.el5 set to be updated
---> Package php-pear-HTTP-Upload.noarch 0:0.9.1-2.el5 set to be updated
---> Package php-pear-Image-Canvas.noarch 0:0.3.1-1.el5 set to be updated
---> Package php-pear-Image-Color.noarch 0:1.0.3-1.el5 set to be updated
---> Package php-pear-Image-Graph.noarch 0:0.8.0-1.el5 set to be updated
---> Package php-pear-Image-GraphViz.noarch 0:1.2.1-4.el5 set to be updated
--> Processing Dependency: graphviz for package: php-pear-Image-GraphViz
---> Package php-pear-Log.noarch 0:1.12.7-1.el5 set to be updated
---> Package php-pear-MDB2.noarch 0:2.4.1-2.el5.centos set to be updated
---> Package php-pear-MDB2-Driver-mysql.noarch 0:1.4.1-3.el5.centos set to be up                                                                                                                      dated
---> Package php-pear-MDB2-Driver-pgsql.noarch 0:1.4.1-1.el5 set to be updated
---> Package php-pear-MDB2-Schema.noarch 0:0.8.0-2.el5 set to be updated
---> Package php-pear-Mail.noarch 0:1.1.14-5.el5.1 set to be updated
---> Package php-pear-Mail-Mime.noarch 0:1.4.0-1.el5.centos set to be updated
---> Package php-pear-Math-Stats.noarch 0:0.9.0-0.1.beta3.el5 set to be updated
---> Package php-pear-Net-Curl.noarch 0:1.2.5-1.el5 set to be updated
---> Package php-pear-Net-DIME.noarch 0:1.0.1-1.el5 set to be updated
---> Package php-pear-Net-FTP.noarch 0:1.3.4-1.el5 set to be updated
---> Package php-pear-Net-POP3.noarch 0:1.3.7-1.el5 set to be updated
---> Package php-pear-Net-Ping.noarch 0:2.4.5-1.el5 set to be updated
---> Package php-pear-Net-SMTP.noarch 0:1.4.4-1.el5 set to be updated
---> Package php-pear-Net-Sieve.noarch 0:1.3.2-1.el5 set to be updated
---> Package php-pear-Net-Socket.noarch 0:1.0.10-1.el5 set to be updated
---> Package php-pear-Net-Traceroute.noarch 0:0.21.3-1.el5 set to be updated
---> Package php-pear-Net-URL.noarch 0:1.0.15-1.el5.centos set to be updated
---> Package php-pear-Net-URL-Mapper.noarch 0:0.9.0-2.el5.1 set to be updated
---> Package php-pear-Net-URL2.noarch 0:0.3.0-1.el5 set to be updated
---> Package php-pear-Net-UserAgent-Detect.noarch 0:2.5.2-1.el5 set to be update                                                                                                                      d
---> Package php-pear-Numbers-Roman.noarch 0:1.0.2-2.el5 set to be updated
---> Package php-pear-Numbers-Words.noarch 0:0.16.1-1.el5 set to be updated
---> Package php-pear-OLE.noarch 0:1.0.0-0.4.rc1.el5 set to be updated
---> Package php-pear-PHP-CodeSniffer.noarch 0:1.2.2-1.el5 set to be updated
---> Package php-pear-PHP-Compat.noarch 0:1.5.0-1.el5 set to be updated
---> Package php-pear-PHP-CompatInfo.noarch 0:1.4.3-1.el5 set to be updated
---> Package php-pear-PHPUnit.noarch 0:3.3.5-2.el5 set to be updated
--> Processing Dependency: php-pecl(Xdebug) >= 2.0.0 for package: php-pear-PHPUn                                                                                                                      it
--> Processing Dependency: php-channel(pear.phpunit.de) for package: php-pear-PH                                                                                                                      PUnit
---> Package php-pear-Pager.noarch 0:2.4.8-1.el5 set to be updated
---> Package php-pear-Payment-Process.noarch 0:0.6.6-1.el5 set to be updated
---> Package php-pear-Phlickr.noarch 0:0.2.7-2.el5 set to be updated
---> Package php-pear-PhpDocumentor.noarch 0:1.4.3-1.el5 set to be updated
--> Processing Dependency: php-Smarty >= 2.6.0 for package: php-pear-PhpDocument                                                                                                                      or
---> Package php-pear-PhpDocumentor-docs.noarch 0:1.4.3-1.el5 set to be updated
---> Package php-pear-SOAP.noarch 0:0.11.0-2.el5 set to be updated
---> Package php-pear-Spreadsheet-Excel-Writer.noarch 0:0.9.2-2.el5 set to be up                                                                                                                      dated
---> Package php-pear-Structures-DataGrid.noarch 0:0.8.3-1.el5 set to be updated
---> Package php-pear-Structures-DataGrid-DataSource-Array.noarch 0:0.1.3-1.el5                                                                                                                       set to be updated
---> Package php-pear-Structures-DataGrid-DataSource-DataObject.noarch 0:0.1.2-1                                                                                                                      .el5 set to be updated
---> Package php-pear-Structures-DataGrid-DataSource-MDB2.noarch 0:0.1.10-1.el5                                                                                                                       set to be updated
---> Package php-pear-Structures-DataGrid-DataSource-RSS.noarch 0:0.1.1-1.el5 se                                                                                                                      t to be updated
---> Package php-pear-Structures-DataGrid-Renderer-Pager.noarch 0:0.1.2-1.el5 se                                                                                                                      t to be updated
---> Package php-pear-Text-Diff.noarch 0:1.1.0-1.el5 set to be updated
---> Package php-pear-Validate.noarch 0:0.8.3-1.el5 set to be updated
---> Package php-pear-Validate-Finance-CreditCard.noarch 0:0.5.2-1.el5 set to be                                                                                                                       updated
---> Package php-pear-Var-Dump.noarch 0:1.0.3-2.el5 set to be updated
---> Package php-pear-XML-Beautifier.noarch 0:1.1-3.el5 set to be updated
---> Package php-pear-XML-Parser.noarch 0:1.2.8-1.el5 set to be updated
---> Package php-pear-XML-RSS.noarch 0:1.0.0-1.el5 set to be updated
---> Package php-pear-XML-Serializer.noarch 0:0.20.0-1.el5 set to be updated
---> Package php-pear-date.noarch 0:1.4.6-1.el5.rf set to be updated
---> Package php-pear-db.noarch 0:1.7.13-2.el5.rf set to be updated
---> Package php-pear-excel.noarch 0:0.9.0-1.el5.rf set to be updated
---> Package php-pear-file.noarch 0:1.2.2-1.el5.rf set to be updated
---> Package php-pear-log.noarch 0:1.9.3-1.el5.rf set to be updated
---> Package php-pear-mail_mime.noarch 0:1.3.1-1.el5.rf set to be updated
---> Package php-pear-ole.noarch 0:0.5-2.el5.rf set to be updated
--> Running transaction check
---> Package graphviz.i386 0:2.22.0-4.el5.rf set to be updated
---> Package php-Smarty.noarch 0:2.6.26-1.el5 set to be updated
---> Package php-channel-phpunit.noarch 0:1.0-2.el5 set to be updated
---> Package php-domxml-php4-php5.noarch 0:1.21.2-1.el5 set to be updated
---> Package php-mcrypt.i386 0:5.2.9-2.el5.centos.3 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
---> Package php-pecl-radius.i386 0:1.2.5-4.el5 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-pecl-radius
---> Package php-pecl-xdebug.i386 0:2.0.5-1.el5.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-pecl-xdebug
--> Finished Dependency Resolution
php-pecl-xdebug-2.0.5-1.el5.1.i386 from epel has depsolving problems
  --> Missing Dependency: php-api = 20041225 is needed by package php-pecl-xdebu                                                                                                                      g-2.0.5-1.el5.1.i386 (epel)
php-pecl-radius-1.2.5-4.el5.i386 from epel has depsolving problems
  --> Missing Dependency: php-api = 20041225 is needed by package php-pecl-radiu                                                                                                                      s-1.2.5-4.el5.i386 (epel)
php-mcrypt-5.2.9-2.el5.centos.3.i386 from c5-testing has depsolving problems
  --> Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.2                                                                                                                      .9-2.el5.centos.3.i386 (c5-testing)
Error: Missing Dependency: php-api = 20041225 is needed by package php-pecl-radi                                                                                                                      us-1.2.5-4.el5.i386 (epel)
Error: Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.                                                                                                                      2.9-2.el5.centos.3.i386 (c5-testing)
Error: Missing Dependency: php-api = 20041225 is needed by package php-pecl-xdeb                                                                                                                      ug-2.0.5-1.el5.1.i386 (epel)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

© Server Fault or respective owner

Related posts about linux

Related posts about php

Categories cloud