Magento - Users unable to login from corporate networks with Bluecoat / F5 Load balancers

Posted by user1330440 on Server Fault See other posts from Server Fault or by user1330440
Published on 2012-04-13T02:37:39Z Indexed on 2012/04/13 5:33 UTC
Read the original article Hit count: 261

Hoping someone has come across this issue before with Magento and corporate clients.

We have two clients for our Magento site who both have their internal networks setup using bluecoat security devices and F5 load balancers. Some users within these networks are unable to login to Magento - Magento eventually is sending a 302 redirect to /index.php/ when users attempt to log in.

Through our testing, the problem appears to be isolated to this setup - we can log into the accounts in question from anywhere outside of these networks without issue, and if the client tries to access the site without going through the F5 load balancer, they are able to log in successfully.

Strangely enough, the issue only started occurring for the two sites the day after we introduced a system upgrade which added a new site to the Magento installation. The system upgrade should not have affected any standard login functionality, and as said, the problem does not appear to be with the users in question, but with where the users are accessing the site from.

Initially we thought the issue might have something to do with communications between the client's networks and the network which the server was hosted on, so we've tried moving the server to different hosts, but this has not helped.

I'm currently waiting for more info from the clients on exact devices / models used in their network setup. I will update this post if more information becomes avaliable.

Magento version is enterprise edition of ver. 1.9.0.0

Does anyone know of any tucked away Magento settings that might be able to cause this kind of behavior? Experience with this kind of set-up and ideas for things to look at?

All help and ideas for things to follow-up would be appreciated - as this is a current production issue for a large number of users. I will respond asap with any requests for additional information on the topic, but currently am not able to disclose any identifying information on the project in question, and/or the clients experiencing issues.

Thanks in advance for any assistance offered :)

Note: This question has also been posted on the Magento forums: http://www.magentocommerce.com/boards/viewthread/277917/ And also on Stack overflow (Moved here as a commenter thought this site may be better suited): http://stackoverflow.com/questions/10133978/magento-users-unable-to-login-from-corporate-networks-with-bluecoat-f5-load

© Server Fault or respective owner

Related posts about networking

Related posts about load-balancing