Munin on Centos 6 - missing perl MODULE_COMPAT_5.8.8

Posted by André Bergonse on Server Fault See other posts from Server Fault or by André Bergonse
Published on 2012-06-22T21:33:15Z Indexed on 2012/06/23 15:17 UTC
Read the original article Hit count: 2252

Filed under:
|
|
|
|

I'm trying to install Munin on a new VPS through yum install munin but I keep getting an error about a missing perl module: Requires: perl(:MODULE_COMPAT_5.8.8). This is the perl version currently installed: v5.10.1.

I've searched all around and still haven't found a solution for this.

Here's the relevant part of the output of the installation attempt:

--> Finished Dependency Resolution
Error: Package: perl-Mail-Sender-0.8.13-2.el5.1.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Log-Log4perl-1.13-2.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Mail-Sendmail-0.79-9.el5.1.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Log-Dispatch-FileRotate-1.16-1.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Crypt-DES-2.05-3.el5.i386 (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: munin-1.4.7-5.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-IO-Multiplex-1.08-5.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: munin-common-1.4.7-5.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Net-Server-0.96-2.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Log-Dispatch-2.20-1.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: munin-1.4.7-5.el5.noarch (epel)
           Requires: bitstream-vera-fonts
Error: Package: perl-Net-SNMP-5.2.0-1.el5.1.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-HTML-Template-2.9-1.el5.2.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-IPC-Shareable-0.60-3.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

© Server Fault or respective owner

Related posts about centos

Related posts about yum