Search Results

Search found 525 results on 21 pages for 'readability'.

Page 8/21 | < Previous Page | 4 5 6 7 8 9 10 11 12 13 14 15  | Next Page >

  • In terms of SEO, is it better to have a URL broken down by folder, or with dashed names?

    - by VictorKilo
    I am creating a friendly url interpreter for my website. I have read dozens of similar topics on this site, but none that seem to address my particular situation. What I want to know is if it's better to have: A well broken down URL where each category is represented by a folder domain.com/1036/OR/Lane/Lowell/Wetleau-Subdivision -OR- A URL which groups all of the categories and terms together domain.com/1036/Wetleau-Subdivision-Lowell-OR-Lane I am asking only in terms of what is best for SEO, not necessarily human readability. My thinking is that it may be better to group them all together like they are in the second example. My reasoning being that all of those terms represent the page and are more likely to draw a result. I am a complete SEO nub though, and I crave some expert guidance. Thank you in advance for any help given.

    Read the article

  • What does well written, readable tests look like?

    - by Industrial
    Doing unit testing for the first time at a large scale, I find myself writing a lot of repetitive unit tests for my business logic. Sure, to create complete test suites I need to test all possibilities but readability feels compromised doing what I do - as shown in the psuedocode below. How would a well written, readable test suit look like? describe "UserEntity" -> it "valid name validates" ... it "invalid name doesnt validate" ... it "valid list of followers validate" ..

    Read the article

  • Should using Eval carry the same stigma as GoTo?

    - by JustSmith
    It is taught in every computer science class and written in many books that programmers should not use GoTo. There is even an xkcd comic about it. My question is have we reached a point where the same thing can be said about Eval? Where GoTo is not conductive for program flow and readability, Eval is the same for debugging, and program execution, and design. Should using Eval have the same stigma as GoTo, and same consequences as in the xkcd comic?

    Read the article

  • Apache BeanUtils.copyProperties is spilling too much log

    - by Ravi Gupta
    How can I switch off logging for BeanUtils.copyProperties ? It creates way too much logs and hampers the log file readability. Thanks heaps.. Sample code BeanUtils.copyProperties(someDataobject,someActionForm); In the log I see hunders of lines like below EBUG org.apache.commons.beanutils.PropertyUtils - setSimpleProperty: Invoking method public void someMethod(java.lang.String) with value null (class ) 2010-03-23 18:53:23,134 DEBUG org.apache.commons.beanutils.BeanUtils - copyProperty(someActionForm@13e38a7, someValue, )

    Read the article

  • Choosing suitable background / foreground colour using PHP

    - by Lizard
    I am looking to find a why to calculate a suitable background colour and a colour for the text that would go over the top, obviously I need to take into account readability and accessibility. I would need to pick the two colours from the array, the colours are stored in their hex representations. #CC9966 #996633 #FFCC99 #CCCC99 #000000 #333333 #666633 #663333 #CC9933 #FFCCCC I can use a PHP library like GD / imageMagick? Any suggestions (Please note I am using PHP)

    Read the article

  • Finite State Machine : Bad design?

    - by f4
    Are Finite State Machines generally considered as bad design in OOP ? I hear that a lot. And, after I had to work on a really old, undocumented piece of C++ making use of it, I tend to agree. It was a pain to debug. what about readability/maintainability concerns?

    Read the article

  • Print and array to a file..

    - by atif089
    Hi, I would like to print an array to a file. I would like the file to look exactly similar like how a code like this looks. print_r ($abc); assuming $abc is an array. Is there any one lines solution for this rather than regular for each look. P.S - I currently use serialie but i want to make the files readable as readability is quite hard with serialized arrays.

    Read the article

  • How to specify the order of XmlAttributes, using XmlSerializer

    - by demoncodemonkey
    XmlElement has an "Order" attribute which you can use to specify the precise order of your properties (in relation to each other anyway) when serializing using XmlSerializer. Is there a similar thing for XmlAttribute? I just want to set the order of the attributes from something like <MyType end="bob" start="joe" /> to <MyType start="joe" end="bob" /> This is just for readability, my own benefit really.

    Read the article

  • How to output formatted HTML from PHP?

    - by Tim
    I like to format all my HTML with tabs for neatness and readability. Recently I started using PHP and now I have a lot of HTML output that comes from in between PHP tags. Those output lines all line up one the left side of the screen. I have to use /n to make a line go to the next. Is there anything like that for forcing tabs, or any way to have neat HTML output coming from PHP?

    Read the article

  • Is there a compelling reason to use quantifiers in Perl regular expressions instead of just repeatin

    - by Morinar
    I was performing a code review for a colleague and he had a regular expression that looked like this: if ($value =~ /^\d\d\d\d$/) { #do stuff } I told him he should change it to: if ($value =~ /^\d{4}$/) { #do stuff } To which he replied that he preferred the first for readability (I find the second more readable, but that's a religious debate I'll save for another day). My question: is there an actual benefit to one over the other?

    Read the article

  • Managing the interval for horizontal axis in flex

    - by Roshan
    Hi Guys, How can we manage the horizontalaxis interval in flex chart? What actually happening is , the data is inserted between two interval levels and its causing readability problem when we draw line grids in graph. The data point is shown in between the data grids. How can we move the axis or manage the data points?

    Read the article

  • Can jQuery add commas while user typing numbers?

    - by Matt
    How would I go about dynamically adding commas as a user is entering numbers? Is there a good number formatter that would help? I have to add these numbers later so I eventually have to remove the commas down the line. But the screen needs to show the commas for better readability.

    Read the article

  • Syntax proposition

    - by Knowing me knowing you
    I wonder if syntax as follows would be helpful in your opinion as a code readability improvent and self-commenting of code: std::map<std::string name, std::vector<int> scores> myMap; In this example it clearly says and no other comment is needed, what for we are using myMap variable. Looking forward to your opinions.

    Read the article

  • Python 2D list has weird behavor when trying to modify a single value...

    - by Brian
    Hi guys, So I am relatively new to Python and I am having trouble working with 2D Lists. Here's my code: data = [[None]*5]*5 data[0][0] = 'Cell A1' print data and here is the output (formatted for readability): [['Cell A1', None, None, None, None], ['Cell A1', None, None, None, None], ['Cell A1', None, None, None, None], ['Cell A1', None, None, None, None], ['Cell A1', None, None, None, None]] Why does every row get assigned the value?

    Read the article

  • Using a visual tool to view changes on git repository

    - by Phuong Nguy?n
    I'm coming to an existing project in which people used git to track everything from scratch. I want to have a tool to view the differences between several commits. gitk does a good job, but talking about human readability, it's does not facilitate me much. Is there a better solution? I'm looking for a set of tools that allow me to easily compare branches (some how like winmerge - Display two version in parallel and highlight the changes), and running on Mac.

    Read the article

  • Use of infix operator hack in production code (Python)

    - by Casebash
    What is your opinion of using the infix operator hack in production code? Issues: The effect this will have on speed. The potential for a clashes with an object with these operators already defined. This seems particularly dangerous with generic code that is intended to handle objects of any type. It is a shame that this isn't built in - it really does improve readability

    Read the article

  • Extension Methods - IsNull and IsNotNull, good or bad use?

    - by Jaimal Chohan
    I like readability. So, I came up with an extension mothod a few minutes ago for the (x =! null) type syntax, called IsNotNull. Inversly, I also created a IsNull extension method, thus if(x == null) becomes if(x.IsNull()) and if(x != null) becomes if(x.IsNotNull()) However, I'm worried I might be abusing extension methods. Do you think that this is bad use of Extenion methods?

    Read the article

  • Language to learn metaprogramming

    - by Erup
    What's the best language (in terms of simplicity, readability and code elegancy) in your opinion, to learn and work with metaprogramming? I think metaprogramming is the "future of coding". Not saying that code will extinct, but we can see this scenario coming on new technologies.

    Read the article

  • Eclipse: view a document using custom spacing, save using the file's spacing

    - by Steven Sproat
    I have a silly use case for eclipse: At work, they use 2 spaces for a tab character. Indentation looks really squashed and I'm finding it obstructs readability. Now, I can't set Eclipse to use 4 spaces for a tab as it'll edit any files I change, and obviously don't want to violate the coding standards. So, can I have a custom view onto my document, with saving maintaining the original spacing? Cheers

    Read the article

  • Is it bad to explicitly compare against boolean constants e.g. if (b == false) in Java?

    - by polygenelubricants
    Is it bad to write: if (b == false) //... while (b != true) //... Is it always better to instead write: if (!b) //... while (!b) //... Presumably there is no difference in performance (or is there?), but how do you weigh the explicitness, the conciseness, the clarity, the readability, etc between the two? Note: the variable name b is just used as an example, ala foo and bar.

    Read the article

< Previous Page | 4 5 6 7 8 9 10 11 12 13 14 15  | Next Page >