Access virtualhosts over LAN (Also in xpmode (Virtual PC))

Posted by Pheter on Stack Overflow See other posts from Stack Overflow or by Pheter
Published on 2010-03-21T00:23:19Z Indexed on 2010/03/21 0:31 UTC
Read the original article Hit count: 523

Hi, I am running Wamp on my computer (the host). I have set up several virtualhosts in apache and they are working fine when I access them from the same computer (host).

I have installed Windows XPMode on my computer (which is running windows 7). XPMode (which uses Virtual PC) is set up to use a NAT network. The network in XPMode is working fine, and I can access the host PC via the IP address 192.168.1.5, just as I would if I was using any physical computer on the same network.

I can view all the web pages at 192.168.1.5 and it's subdirectories. However, I cannot access any of the subdomains that are configured in the virtualhosts of the host computer.

How can I access the subdomains? I don't think that the fact that I am using XPMode and am using a virtualized OS has anything to do with it, but I thought that it was worth mentioning.

© Stack Overflow or respective owner

Access virtualhosts over LAN (Also in xpmode (Virtual PC))

Posted by Pheter on Server Fault See other posts from Server Fault or by Pheter
Published on 2010-03-21T00:23:19Z Indexed on 2010/03/21 1:21 UTC
Read the original article Hit count: 523

Hi, I am running Wamp on my computer (the host). I have set up several virtualhosts in apache and they are working fine when I access them from the same computer (host).

I have installed Windows XPMode on my computer (which is running windows 7). XPMode (which uses Virtual PC) is set up to use a NAT network. The network in XPMode is working fine, and I can access the host PC via the IP address 192.168.1.5, just as I would if I was using any physical computer on the same network.

I can view all the web pages at 192.168.1.5 and it's subdirectories. However, I cannot access any of the subdomains that are configured in the virtualhosts of the host computer.

How can I access the subdomains? I don't think that the fact that I am using XPMode and am using a virtualized OS has anything to do with it, but I thought that it was worth mentioning.

© Server Fault or respective owner

Related posts about networking

Related posts about virtualization