App-V Problems After SCCM 2007 SP2 Upgrade

Posted by GAThrawn on Server Fault See other posts from Server Fault or by GAThrawn
Published on 2010-01-26T11:30:12Z Indexed on 2010/03/29 10:53 UTC
Read the original article Hit count: 283

Filed under:
|
|
|

We're running an SCCM (MS System Centre Config Manager, successor to SMS) 2007 environment and delivering a number of applications to clients virtualized using App-V 4.5.1. The App-V apps are delivered by SCCM in Download-and-Execute, not streaming mode.

The SCCM environment was recently service packed to SCCM 2007 SP2 (amongst other things this gives Win7 support). We also pushed out the updated SCCM clients to our workstations. This seems to have broken file associations for virtual apps for a large number of our users. The users can still open their App-V apps by finding the specific app on their Start Menu and clicking it's icon, but double-clicking an associated file in Explorer, or opening an email attachment gives the "This action is only valid for installed applications" error.

There is a Technet blog entry from the App-V team talking about this issue "Upgrade to ConfigMgr 2007 SP2 may break App-V File Type Associations" but running the script there comes back saying "The User Interface option has been updated" but hasn't seemed to fix the problems for any of our users. Unfortunately the Technet blogs don't seem to have comments switched on so you can't see how this has worked out for other people.

Anyone else had this problem, have you found any other way to fix it?

© Server Fault or respective owner

Related posts about sccm

Related posts about upgrade