Stuck with Apache2

Posted by Gundars Meness on Ask Ubuntu See other posts from Ask Ubuntu or by Gundars Meness
Published on 2012-09-10T05:02:03Z Indexed on 2012/09/10 9:48 UTC
Read the original article Hit count: 540

Filed under:
|
|

I cant finish Apache2 install, also cannot remove it. It has blocked my dpkg, now I cant get no installations in or out. I even tried distro upgrade, but it did still has broken dpkg..

How to fix this and get normal Apache2 running?

Just for the heck of it:

[email protected]:~$ sudo apt-get remove apache2-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'apache2-common' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up apache2.2-common (2.2.22-6ubuntu2) ...
ERROR: Site default does not exist!
dpkg: error processing apache2.2-common (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of apache2-mpm-prefork:
 apache2-mpm-prefork depends on apache2.2-common (= 2.2.22-6ubuntu2); however:
  Package apache2.2-common is not configured yet.

dpkg: error processing apache2-mpm-prefork (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 apache2.2-common
 apache2-mpm-prefork
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt-get -f install apache2 apache2.2-common apache2-mpm-prefork

[sudo] password for gundars: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
apache2 is already the newest version.
apache2-mpm-prefork is already the newest version.
apache2.2-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up apache2.2-common (2.2.22-6ubuntu2) ...
ERROR: Site default does not exist!
dpkg: error processing apache2.2-common (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of apache2-mpm-prefork:
 apache2-mpm-prefork depends on apache2.2-common (= 2.2.22-6ubuntu2); however:
  Package apache2.2-common is not configured yet.

dpkg: error processing apache2-mpm-prefork (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of apache2:
 apache2 depends on apache2-mpm-worker (= 2.2.22-6ubuntu2) | apache2-mpm-prefork (= 2.2.22-6ubuntu2) | apache2-mpm-event (= 2.2.22-6ubuntu2) | apache2-mpm-itk (= 2.2.22-6ubuntu2); however:
  Package apache2-mpm-worker is not installed.
  Package apache2-mpm-prefork is not configured yet.
  Package apache2-mpm-event is not installed.
  Package apache2-mpm-itk is not installed.
 apache2 depends on apache2.2-common (= 2.2.22-6ubuntu2); however:
  Package apache2.2-common is not configured yet.

dpkg: error processing apache2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libapache2-mod-php5:
 libapache2-mod-php5 depends on apache2-mpm-prefork (>> 2.0.52) | apache2-mpm-itk; however:
  Package apache2-mpm-prefork is not configured yet.
  Package apache2-mpm-itk is not installed.
 libapache2-mod-php5 depends on apache2.2-common; however:
  Package apache2.2-common is not configured yet.

No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                            dpkg: error processing libapache2-mod-php5 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 apache2.2-common
 apache2-mpm-prefork
 apache2
 libapache2-mod-php5
E: Sub-process /usr/bin/dpkg returned an error code (1)

© Ask Ubuntu or respective owner

Related posts about server

Related posts about apache