1.5 TB USB Drive failed to mount

Posted by user89348 on Ask Ubuntu See other posts from Ask Ubuntu or by user89348
Published on 2012-10-12T04:31:35Z Indexed on 2012/10/20 5:22 UTC
Read the original article Hit count: 192

Filed under:
|
|
|
|

Seagate 1.5Tb FreeAgent USB Hard Drive. Formatted FAT32. I figure it is 75% full. Used to work fine in XUBUNTU it shows up in Cairo Dock but when I click on it I get "failed to mount drive'. Nautilus does not display the icon nor does Thunar. Windows Vista will no longer recognise drive either. Back Track 5R3 also no longer fails to mount it. BUT and here is the BIG BUT my Pioneer DV-410 reads the files and plays the everything just fine.

I believe this all happened after an unclean shutdown / XUbuntu 12.10 system freeze. Why can't XUBUNTU mount this drive when a crappy 13 year old DVD player can mount it. I am desperate to back up the data before just in case the drive becomes completely unreadable.

Using XUBUNTU 12.10 Quantal current 3.5.0.17 Kernel (past 3 Kernels wont read it either) and all newest apt-get update / dist-upgrade are applied. I will post any other info you folks request as needed.


Additional info as requested by githlar.

$ sudo fsck.vfat /dev/sdb
dosfsck 3.0.13, 30 Jun 2012, FAT32, LFN
Read 512 bytes at 0:Input/output error

$ lsusb
Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 002 Device 002: ID 0bc2:3001 Seagate RSS LLC
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

© Ask Ubuntu or respective owner

Related posts about mount

Related posts about xubuntu