Wired PS/2 Keyboard and Mouse do not work in 12.04 Live CD or after fresh 12.04 install - Foxconn D270S Atom Motherboard

Posted by david krajewski on Ask Ubuntu See other posts from Ask Ubuntu or by david krajewski
Published on 2012-05-04T02:47:12Z Indexed on 2012/11/08 17:24 UTC
Read the original article Hit count: 481

Filed under:
|
|

My Wired PS/2 keyboard and mouse do not work in 12.04, either in a fresh install or from the Live CD. A USB keyboard and mouse will work. The PS/2 keyboard and mouse will work using the same hardware and a fresh 10.04 Ubuntu install or a fresh Windows 7 install. The motherboard is a Foxconn D270S Atom based motherboard. This problem is specific to this motherboard and Ubuntu 12.04.

So far I've tried running in the fresh 12.04 install:

sudo apt-get install

sudo apt-get upgrade

sudo apt-get dist-upgrade

After the apt-get upgraded the first time, I now get to the point where there are 0 items to be upgraded. Rebooted and still no PS/2 keyboard/mouse.

I've also tried adding the following lines to GRUB at boot time (the PS/2 keyboard works in GRUB)

acpi=noirq

acpi=off

Neither setting made any difference.

The motherboard is a Foxconn D270S Atom based motherboard. Even more interestingly, 12.04 recognizes the same PS/2 keyboard and mouse on a separate Gigabyte AM3+ based motherboard. I only have this problem on this particular motherboard with Ubuntu 12.04.

Any help would be appreciated. I bought this low-power motherboard specifically for the task of running Ubuntu 12.04 for the next five years...

Update...

I dug out an old PS/2 mouse that does not use a PS/2 to USB adapter but is directly wired for PS/2. Still no PS/2 keyboard or mouse after reboot. Again, I only have this problem with this motherboard and 12.04 Ubuntu. Other motherboards work fine with 12.04 and this motherboard works fine with 10.04.

Update 2...

I installed the 12.04 Server version. The text-based installer recognized the keyboard without issue, but after the first boot into the installed OS, the PS/2 keyboard would no longer respond. I tried installing Gnome on the Server install and the PS/2 mouse and keyboard don't work in Gnome either.

I Opened bug #995570 for this issue

© Ask Ubuntu or respective owner

Related posts about 12.04

Related posts about keyboard