Can't log in to GNOME after upgrade (raring -> saucy)

Posted by x-yuri on Ask Ubuntu See other posts from Ask Ubuntu or by x-yuri
Published on 2013-10-18T03:28:47Z Indexed on 2013/10/18 4:12 UTC
Read the original article Hit count: 229

Filed under:
|
|
|

I've just upgraded my ubuntu (raring to saucy) and I now can't log in to GNOME. As opposed to virtual consoles (Ctrl-Alt-F1, for example). I set it up to log in automatically. But it asks for password now. I type in the password, press Enter, the screen blinks and here I am again at the login screen. Then I looked into /var/log/Xorg.0.log:

[    33.956] Initializing built-in extension DRI2
[    33.956] (II) LoadModule: "glx"
[    33.956] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    33.956] (II) Module glx: vendor="X.Org Foundation"
[    33.956]    compiled for 1.14.3, module version = 1.0.0
[    33.956]    ABI class: X.Org Server Extension, version 7.0
[    33.956] (==) AIGLX enabled
[    33.956] Loading extension GLX
[    33.956] (==) Matched fglrx as autoconfigured driver 0
[    33.956] (==) Matched ati as autoconfigured driver 1
[    33.956] (==) Matched fglrx as autoconfigured driver 2
[    33.956] (==) Matched ati as autoconfigured driver 3
[    33.956] (==) Matched vesa as autoconfigured driver 4
[    33.956] (==) Matched modesetting as autoconfigured driver 5
[    33.956] (==) Matched fbdev as autoconfigured driver 6
[    33.956] (==) Assigned the driver to the xf86ConfigLayout
[    33.956] (II) LoadModule: "fglrx"
[    33.957] (WW) Warning, couldn't open module fglrx
[    33.957] (II) UnloadModule: "fglrx"
[    33.957] (II) Unloading fglrx
[    33.957] (EE) Failed to load module "fglrx" (module does not exist, 0)
[    33.957] (II) LoadModule: "ati"
[    33.957] (WW) Warning, couldn't open module ati
[    33.957] (II) UnloadModule: "ati"
[    33.957] (II) Unloading ati
[    33.957] (EE) Failed to load module "ati" (module does not exist, 0)
[    33.957] (II) LoadModule: "vesa"
[    33.957] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    33.957] (II) Module vesa: vendor="X.Org Foundation"
[    33.957]    compiled for 1.14.1, module version = 2.3.2
[    33.957]    Module class: X.Org Video Driver
[    33.957]    ABI class: X.Org Video Driver, version 14.1
[    33.957] (II) LoadModule: "modesetting"
[    33.957] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    33.957] (II) Module modesetting: vendor="X.Org Foundation"
[    33.957]    compiled for 1.14.1, module version = 0.8.0
[    33.957]    Module class: X.Org Video Driver
[    33.957]    ABI class: X.Org Video Driver, version 14.1
[    33.957] (II) LoadModule: "fbdev"
[    33.957] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    33.958] (II) Module fbdev: vendor="X.Org Foundation"
[    33.958]    compiled for 1.14.1, module version = 0.4.3
[    33.958]    Module class: X.Org Video Driver
[    33.958]    ABI class: X.Org Video Driver, version 14.1
[    33.958] (==) Matched fglrx as autoconfigured driver 0
[    33.958] (==) Matched ati as autoconfigured driver 1
[    33.958] (==) Matched fglrx as autoconfigured driver 2
[    33.958] (==) Matched ati as autoconfigured driver 3
[    33.958] (==) Matched vesa as autoconfigured driver 4
[    33.958] (==) Matched modesetting as autoconfigured driver 5
[    33.958] (==) Matched fbdev as autoconfigured driver 6
[    33.958] (==) Assigned the driver to the xf86ConfigLayout
[    33.958] (II) LoadModule: "fglrx"
[    33.958] (WW) Warning, couldn't open module fglrx
[    33.958] (II) UnloadModule: "fglrx"
[    33.958] (II) Unloading fglrx
[    33.958] (EE) Failed to load module "fglrx" (module does not exist, 0)
[    33.958] (II) LoadModule: "ati"
[    33.958] (WW) Warning, couldn't open module ati
[    33.958] (II) UnloadModule: "ati"
[    33.958] (II) Unloading ati
[    33.958] (EE) Failed to load module "ati" (module does not exist, 0)
[    33.958] (II) LoadModule: "vesa"
[    33.958] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    33.958] (II) Module vesa: vendor="X.Org Foundation"
[    33.958]    compiled for 1.14.1, module version = 2.3.2
[    33.958]    Module class: X.Org Video Driver
[    33.958]    ABI class: X.Org Video Driver, version 14.1
[    33.958] (II) UnloadModule: "vesa"
[    33.958] (II) Unloading vesa
[    33.958] (II) Failed to load module "vesa" (already loaded, 0)
[    33.958] (II) LoadModule: "modesetting"
[    33.959] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    33.959] (II) Module modesetting: vendor="X.Org Foundation"
[    33.959]    compiled for 1.14.1, module version = 0.8.0
[    33.959]    Module class: X.Org Video Driver
[    33.959]    ABI class: X.Org Video Driver, version 14.1
[    33.959] (II) UnloadModule: "modesetting"
[    33.959] (II) Unloading modesetting
[    33.959] (II) Failed to load module "modesetting" (already loaded, 0)
[    33.959] (II) LoadModule: "fbdev"
[    33.959] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    33.959] (II) Module fbdev: vendor="X.Org Foundation"
[    33.959]    compiled for 1.14.1, module version = 0.4.3
[    33.959]    Module class: X.Org Video Driver
[    33.959]    ABI class: X.Org Video Driver, version 14.1
[    33.959] (II) UnloadModule: "fbdev"
[    33.959] (II) Unloading fbdev
[    33.959] (II) Failed to load module "fbdev" (already loaded, 0)
[    33.959] (II) VESA: driver for VESA chipsets: vesa
[    33.959] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    33.959] (II) FBDEV: driver for framebuffer: fbdev
[    33.959] (++) using VT number 7

If I install fglrx, it reads:

[    37.152] Initializing built-in extension DRI2
[    37.152] (II) LoadModule: "glx"
[    37.152] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/extensions/libglx.so
[    37.152] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    37.152]    compiled for 6.9.0, module version = 1.0.0
[    37.152] Loading extension GLX
[    37.153] (==) Matched fglrx as autoconfigured driver 0
[    37.153] (==) Matched ati as autoconfigured driver 1
[    37.153] (==) Matched vesa as autoconfigured driver 2
[    37.153] (==) Matched modesetting as autoconfigured driver 3
[    37.153] (==) Matched fbdev as autoconfigured driver 4
[    37.153] (==) Assigned the driver to the xf86ConfigLayout
[    37.153] (II) LoadModule: "fglrx"
[    37.153] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so
[    37.168] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    37.168]    compiled for 1.4.99.906, module version = 13.10.10
[    37.168]    Module class: X.Org Video Driver
[    37.168] (II) Loading sub module "fglrxdrm"
[    37.168] (II) LoadModule: "fglrxdrm"
[    37.168] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/linux/libfglrxdrm.so
[    37.169] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    37.169]    compiled for 1.4.99.906, module version = 13.10.10
[    37.169] (II) LoadModule: "ati"
[    37.169] (WW) Warning, couldn't open module ati
[    37.169] (II) UnloadModule: "ati"
[    37.169] (II) Unloading ati
[    37.169] (EE) Failed to load module "ati" (module does not exist, 0)
[    37.169] (II) LoadModule: "vesa"
[    37.169] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    37.169] (II) Module vesa: vendor="X.Org Foundation"
[    37.169]    compiled for 1.14.1, module version = 2.3.2
[    37.169]    Module class: X.Org Video Driver
[    37.169]    ABI class: X.Org Video Driver, version 14.1
[    37.169] (II) LoadModule: "modesetting"
[    37.170] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    37.170] (II) Module modesetting: vendor="X.Org Foundation"
[    37.170]    compiled for 1.14.1, module version = 0.8.0
[    37.170]    Module class: X.Org Video Driver
[    37.170]    ABI class: X.Org Video Driver, version 14.1
[    37.170] (II) LoadModule: "fbdev"
[    37.170] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    37.170] (II) Module fbdev: vendor="X.Org Foundation"
[    37.170]    compiled for 1.14.1, module version = 0.4.3
[    37.170]    Module class: X.Org Video Driver
[    37.170]    ABI class: X.Org Video Driver, version 14.1
[    37.170] (==) Matched fglrx as autoconfigured driver 0
[    37.170] (==) Matched ati as autoconfigured driver 1
[    37.170] (==) Matched vesa as autoconfigured driver 2
[    37.170] (==) Matched modesetting as autoconfigured driver 3
[    37.170] (==) Matched fbdev as autoconfigured driver 4
[    37.170] (==) Assigned the driver to the xf86ConfigLayout
[    37.170] (II) LoadModule: "fglrx"
[    37.170] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so
[    37.170] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    37.170]    compiled for 1.4.99.906, module version = 13.10.10
[    37.170]    Module class: X.Org Video Driver
[    37.170] (II) LoadModule: "ati"
[    37.170] (WW) Warning, couldn't open module ati
[    37.170] (II) UnloadModule: "ati"
[    37.171] (II) Unloading ati
[    37.171] (EE) Failed to load module "ati" (module does not exist, 0)
[    37.171] (II) LoadModule: "vesa"
[    37.171] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    37.171] (II) Module vesa: vendor="X.Org Foundation"
[    37.171]    compiled for 1.14.1, module version = 2.3.2
[    37.171]    Module class: X.Org Video Driver
[    37.171]    ABI class: X.Org Video Driver, version 14.1
[    37.171] (II) UnloadModule: "vesa"
[    37.171] (II) Unloading vesa
[    37.171] (II) Failed to load module "vesa" (already loaded, 0)
[    37.171] (II) LoadModule: "modesetting"
[    37.171] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    37.171] (II) Module modesetting: vendor="X.Org Foundation"
[    37.171]    compiled for 1.14.1, module version = 0.8.0
[    37.171]    Module class: X.Org Video Driver
[    37.171]    ABI class: X.Org Video Driver, version 14.1
[    37.171] (II) UnloadModule: "modesetting"
[    37.171] (II) Unloading modesetting
[    37.171] (II) Failed to load module "modesetting" (already loaded, 0)
[    37.171] (II) LoadModule: "fbdev"
[    37.171] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    37.171] (II) Module fbdev: vendor="X.Org Foundation"
[    37.171]    compiled for 1.14.1, module version = 0.4.3
[    37.171]    Module class: X.Org Video Driver
[    37.171]    ABI class: X.Org Video Driver, version 14.1
[    37.171] (II) UnloadModule: "fbdev"
[    37.171] (II) Unloading fbdev
[    37.171] (II) Failed to load module "fbdev" (already loaded, 0)
[    37.171] (II) AMD Proprietary Linux Driver Version Identifier:13.10.10
[    37.171] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-13.101                   
[    37.171] (II) AMD Proprietary Linux Driver Build Date: May 23 2013 15:49:35
[    37.171] (II) VESA: driver for VESA chipsets: vesa
[    37.171] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    37.171] (II) FBDEV: driver for framebuffer: fbdev
[    37.171] (++) using VT number 7

I did more installing/removing packages than that. There were a moment when it said:

(EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/lib64/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context

Also there is init: not found in ~/.xsession-errors:

/usr/sbin/lightdm-session: 5: exec: init: not found

Actually, I'm out of ideas. What about you? :)

© Ask Ubuntu or respective owner

Related posts about 13.04

Related posts about upgrade