URGENT: Firefox circular-dependency hell - Linux Mint 13 (based on Ubuntu 12.04)

Posted by Tyler J Fisher on Ask Ubuntu See other posts from Ask Ubuntu or by Tyler J Fisher
Published on 2012-10-27T23:14:10Z Indexed on 2012/10/27 23:19 UTC
Read the original article Hit count: 935

Filed under:
|
|

Having difficulty re-installing Firefox, after an installation to resolve places.sqlite issues. It appears that I'm trapped in circular dependency hell.

Need to resolve firefox dependency hell to attempt to resolve Tomcat6 project dependencies (don't ask), ASAP. Have been trying for hours.

What I've done (brief) 1) sudo apt-get purge firefox firefox-globalmenu firefox-gnome-support 2) sudo apt-get update 3) sudo apt-get install firefox firefox-globalmenu firefox-gnome-support 4) sudo apt-get -f install


Potential error sources: Found in(sudo apt-get install firefox firefox-globalmenu firefox-gnome-support)

dpkg: error processing /var/cache/apt/archives/firefox_18.0~a2~hg20121027r113701-0ubuntu1~umd1~precise_amd64.deb (--unpack): trying to overwrite '/usr/lib/firefox/extensions', which is also in package mint-search-addon 2012.05.11

So, /usr/lib/firefox/extensions doesn't even EXIST! Deleted /var/cache/apt/archives/firefox_18.0~a2~hg20121027r113701 as per recommendations.


Errors were encountered while processing: /var/cache/apt/archives/firefox_18.0~a2~hg20121027r113701-0ubuntu1~umd1~precise_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)



Outputs: 1) sudo apt-get purge firefox firefox-globalmenu firefox-gnome-support

me@machine ~ $ sudo apt-get purge firefox-gnome-support firefox firefox-globalmenu

Reading package lists... Done

Building dependency tree

Reading state information... Done Package firefox is not installed, so not removed

The following packages will be REMOVED:

firefox-globalmenu* firefox-gnome-support* 2 not fully installed or removed. 0 upgraded, 0 newly installed, 2 to remove and 38 not upgraded.

After this operation, 460 kB disk space will be freed.

Do you want to continue [Y/n]? y

(Reading database ... dpkg: warning: files list file for package `mysqltuner' missing, > assuming package has no files currently installed.

(Reading database ... 192642 files and directories currently installed.)

Removing firefox-globalmenu ...

Removing firefox-gnome-support ...

3) me@machine ~ $ sudo apt-get install firefox firefox-globalmenu firefox-gnome-support

Reading package lists... Done

Building dependency tree
Reading state information... Done

Suggested packages: latex-xft-fonts

The following NEW packages will be installed: firefox firefox-globalmenu firefox-gnome-support

0 upgraded, 3 newly installed, 0 to remove and 38 not upgraded.

Need to get 0 B/24.8 MB of archives.

After this operation, 54.3 MB of additional disk space will be used.

(Reading database ...

dpkg: warning: files list file for package `mysqltuner' missing, assuming package has no files currently installed.

(Reading database ... 192619 files and directories currently installed.)

Unpacking firefox (from .../firefox_18.0~a2~hg20121027r113701-0ubuntu1~umd1~precise_amd64.deb) ...

dpkg: error processing /var/cache/apt/archives/firefox_18.0~a2~hg20121027r113701-0ubuntu1~umd1~precise_amd64.deb (--unpack):

trying to overwrite '/usr/lib/firefox/extensions', which is also in package mint-search-addon 2012.05.11

Selecting previously unselected package firefox-globalmenu.

Unpacking firefox-globalmenu (from .../firefox-globalmenu_18.0~a2~hg20121027r113701-0ubuntu1~umd1~precise_amd64.deb) ...

Selecting previously unselected package firefox-gnome-support.

Unpacking firefox-gnome-support (from .../firefox-gnome- support_18.0~a2~hg20121027r113701-0ubuntu1~umd1~precise_amd64.deb) ...

Processing triggers for man-db ...

Processing triggers for desktop-file-utils ...

Processing triggers for bamfdaemon ...

Rebuilding /usr/share/applications/bamf.index...

Processing triggers for gnome-menus ...

Processing triggers for mintsystem ...

Errors were encountered while processing: /var/cache/apt/archives/firefox_18.0~a2~hg20121027r113701-

0ubuntu1~umd1~precise_amd64.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

4) sudo apt-get -f install

  • 0 upgraded, 0 newly installed, 0 to remove, and 38 not upgraded

Ideas? Tomcat6 only deploys my web application successfully in Firefox, not Chrome, so I'm really hoping to resolve this dependency issue.

© Ask Ubuntu or respective owner

Related posts about 12.04

Related posts about firefox