PHP Composer Not Working On Mac

Posted by Richard Knop on Server Fault See other posts from Server Fault or by Richard Knop
Published on 2012-11-24T21:09:13Z Indexed on 2012/11/24 23:05 UTC
Read the original article Hit count: 334

Filed under:
|
|
|

I have installed a bitnami mac stack mainly because I require at least PHP 5.4.7 version for my project. However, I have run into an issue with composer. This is the error I get when I run:

php composer.phar install --dev

The error:

Richard-Knops-MacBook-Pro:my-project richardknop$ php composer.phar install --dev
dyld: Library not loaded: /Applications/MAMP/Library/lib/libiconv.2.dylib
  Referenced from: /opt/local/bin/php
  Reason: Incompatible library version: php requires version 8.0.0 or later, but libiconv.2.dylib provides version 7.0.0
Trace/BPT trap
Richard-Knops-MacBook-Pro:my-project richardknop$

How to solve it?

© Server Fault or respective owner

Related posts about php

Related posts about macosx